PHP vulnerability CVE-2010-4156

2011-02-11T02:17:00
ID F5:K12597
Type f5
Reporter f5
Modified 2016-01-09T02:24:00

Description

Note: For information about signing up to receive security notice updates from F5, refer to K9970: Subscribing to email notifications regarding F5 products.

Note: Versions that are not listed in this article have not been evaluated for vulnerability to this security advisory. For information about the F5 security policy regarding evaluating older and unsupported versions of F5 products, refer to K4602: Overview of the F5 security vulnerability response policy.

F5 products and versions that have been evaluated for this Security Advisory

Product | Affected | Not Affected
---|---|---
BIG-IP LTM | None | 9.x
10.x
11.x
BIG-IP GTM | None | 9.x
10.x
11.x
BIG-IP ASM | None | 9.x
10.x
11.x
BIG-IP Link Controller | None | 9.x
10.x
11.x

BIG-IP WebAccelerator | None | 9.x
10.x
11.x
BIG-IP PSM | None | 9.x
10.x
11.x
BIG-IP WOM | None | 10.x
11.x
BIG-IP APM | None | 10.x
11.x
BIG-IP Edge Gateway | None | 10.x
11.x
BIG-IP Analytics | None | 11.x
BIG-IP AFM | None | 11.x
BIG-IP PEM | None | 11.x
BIG-IP AAM | None | 11.x
FirePass | None | 5.x
6.x
7.x
Enterprise Manager | None | 1.x
2.x
3.x
ARX | None | 2.x
3.x
4.x
5.x
6.x

Vulnerability description and product information

PHP vulnerability CVE-2010-4156 describes a vulnerability where the mb_strcut function in Libmbfl 1.1.0, as used in PHP 5.3.x through 5.3.3, allows context-dependent attackers to obtain potentially sensitive information via a large value of the third parameter (aka the length parameter).

Information about this advisory is available at the following location:

<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-4156>