Bandersnatch 0.4 - Multiple Input Validation Vulnerabilities

2007-07-27T00:00:00
ID EXPLOITPACK:E166AE88D4FA0D3D823BF427122174A1
Type exploitpack
Reporter Tim Brown
Modified 2007-07-27T00:00:00

Description

Bandersnatch 0.4 - Multiple Input Validation Vulnerabilities

                                        
                                            source: https://www.securityfocus.com/bid/25094/info

Bandersnatch is prone to multiple input-validation vulnerabilities because the application fails to sanitize user-supplied input. These issues include multiple SQL-injections vulnerabilities and an HTML-injection vulnerability.

A successful exploit may allow an attacker to steal cookie-based authentication credentials, execute malicious script code, compromise the application, access or modify data, or exploit latent vulnerabilities in the underlying database.

This issue affects Bandersnatch 0.4; other versions may also be affected. 

http://www.example.com/index.php?date=[SQL]
http://www.example.com/index.php?limit=[SQL]