phpShop 0.8.1 - page Cross-Site Scripting

2011-02-25T00:00:00
ID EXPLOITPACK:DF1B8B03FBBF199FA6870B2060C733DF
Type exploitpack
Reporter Aung Khant
Modified 2011-02-25T00:00:00

Description

phpShop 0.8.1 - page Cross-Site Scripting

                                        
                                            source: https://www.securityfocus.com/bid/46561/info

phpShop is prone to a cross-site scripting vulnerability because it fails to sufficiently sanitize user-supplied data.

An attacker may leverage this issue to execute arbitrary HTML and script code in the browser of an unsuspecting user in the context of the affected site. This may allow the attacker to steal cookie-based authentication credentials and to launch other attacks.

phpShop versions 0.8.1 and prior are vulnerable. 

http://www.example.com/phpshop0_8_1/?page=store/XSS&%26%26%22%3E%3Cscript%3Ealert%28/xss/%29%3C/script%3E%3d1