PostNuke 0.6x0.7x NS-Languages Module - language Cross-Site Scripting

2006-02-21T00:00:00
ID EXPLOITPACK:A779D44889A0A9D47CB1EA970045B8D0
Type exploitpack
Reporter Maksymilian Arciemowicz
Modified 2006-02-21T00:00:00

Description

PostNuke 0.6x0.7x NS-Languages Module - language Cross-Site Scripting

                                        
                                            source: https://www.securityfocus.com/bid/16752/info

PostNuke is prone to multiple input-validation vulnerabilities. These issues are due to the application's failure to properly sanitize user-supplied input. 

Successful exploitation could allow an attacker to compromise the application, access or modify data, steal cookie-based authentication credentials, exploit vulnerabilities in the underlying database implementation, or control how the site is rendered to the user. Other attacks are also possible.

http://www.example.com/admin.php?module=NS-Languages&op=missing&language=">[code]
http://www.example.com/admin.php?module=NS-Languages&op=translation&language=[code]