UMI CMS 2.7 - fields_filter Cross-Site Scripting

2009-03-06T00:00:00
ID EXPLOITPACK:8C08E4AE5C5CD8B94774B69779F1282A
Type exploitpack
Reporter Dmitriy Evteev
Modified 2009-03-06T00:00:00

Description

UMI CMS 2.7 - fields_filter Cross-Site Scripting

                                        
                                            source: https://www.securityfocus.com/bid/34018/info

UMI CMS is prone to a cross-site scripting vulnerability because it fails to sufficiently sanitize user-supplied data.

An attacker may leverage this issue to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This may allow the attacker to steal cookie-based authentication credentials and to launch other attacks.

Versions prior to UMI CMS 2.7.1 (build 10856) are vulnerable. 

http://www.example.com/market/[content_dir]/?fields_filter[price][0]=%22%3E%3Cscript%3Ealert('XSS')%3C/script%3E&fields_filter[price][1]=1