Invision Power Board (IP.Board) 1.3 - SSI.php Cross-Site Scripting

2004-06-14T00:00:00
ID EXPLOITPACK:58E86D90E2739216429DF0CCDC91092A
Type exploitpack
Reporter IMAN Sharafoddin
Modified 2004-06-14T00:00:00

Description

Invision Power Board (IP.Board) 1.3 - SSI.php Cross-Site Scripting

                                        
                                            source: https://www.securityfocus.com/bid/10539/info

Invision Power Board 'ssi.php' script reported prone to a cross-site scripting vulnerability. The issue presents itself due to a lack of sufficient sanitization performed by functions in the 'ssi.php' script on user-influenced 'f' parameter. This can permit the theft of cookie-based authentication credentials; other attacks may also be possible.

http://www.example.com/hyper/ssi.php?a=out&type=xml&f=<script>alert("ALOooooooooo");</script>