Libmusicbrainz 2.0.22.1.x - Multiple Buffer Overflow Vulnerabilities

2006-08-14T00:00:00
ID EXPLOITPACK:460E37FD19CA8EF63431F7142F2BBA16
Type exploitpack
Reporter Luigi Auriemma
Modified 2006-08-14T00:00:00

Description

Libmusicbrainz 2.0.22.1.x - Multiple Buffer Overflow Vulnerabilities

                                        
                                            source: https://www.securityfocus.com/bid/19508/info

The libmusicbrainz library is prone to multiple buffer-overflow vulnerabilities because the application fails to check the size of the data before copying it into a finite-sized internal memory buffer. 

An attacker can exploit these issues to execute arbitrary code within the context of the application or to cause a denial-of-service condition. 

Versions 2.1.2, SVN 8406, and prior are vulnerable to this issue; other versions may also be affected.

https://github.com/offensive-security/exploitdb-bin-sploits/raw/master/bin-sploits/28384.zip