python-feedparser 5.0 - feedparserfeedparser.py Cross-Site Scripting

2011-04-05T00:00:00
ID EXPLOITPACK:406D9F67BEEEEDE0780DCBED744E3545
Type exploitpack
Reporter fazalmajid
Modified 2011-04-05T00:00:00

Description

python-feedparser 5.0 - feedparserfeedparser.py Cross-Site Scripting

                                        
                                            source: https://www.securityfocus.com/bid/47177/info


python-feedparser is prone to a cross-site scripting vulnerability because it fails to properly sanitize user-supplied input.

An attacker may leverage this issue to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This can allow the attacker to steal cookie-based authentication credentials and launch other attacks. 

<!--
Description: ensure nested CDATA sections are sanitized properly
Expect: bozo and entries[0]['content'][0]['value'] == u'<![CDATA[]]>'
-->
<rss xmlns:content="http://www.example.com/rss/1.0/modules/content/" version="2.0">
<channel>
  <item>
    <content:encoded><![CDATA[<![CDATA[<script></script>]]>]]></content:encoded>
  </item>
</channel>
</rss