NEPT Image Uploader 1.0 - Arbitrary Shell Upload Vulnerability

2008-10-24T00:00:00
ID EDB-ID:6830
Type exploitdb
Reporter Dentrasi
Modified 2008-10-24T00:00:00

Description

NEPT Image Uploader 1.0 Arbitrary Shell Upload Vulnerability. CVE-2008-6822. Webapps exploit for php platform

                                        
                                            //Title - NEPT Image Uploader shell upload

//Vendor - newearthpt.freehostia.com

//Version - 1.0

//Status - vendor has been notified

//Author - Dentrasi

//Description

It is possible to upload a php script to the remote site.


1. Select a php file for upload
2. Select it for upload, and tamperdata the request
3. Change the Content-Type from 'application/octet-stream' to 'image/jpeg'
4. If the link provided gives a 404, add 'upload/' before the file name

# milw0rm.com [2008-10-24]