Crafty Syntax Live Help <= 3.1.2 Remote File Include and Path Disclosure Vulnerabilities

2013-04-19T00:00:00
ID EDB-ID:38482
Type exploitdb
Reporter ITTIHACK
Modified 2013-04-19T00:00:00

Description

Crafty Syntax Live Help 3.1.2 Remote File Include and Path Disclosure Vulnerabilities. Webapps exploit for php platform

                                        
                                            source: http://www.securityfocus.com/bid/59322/info

Crafty Syntax Live Help is prone to a remote file-include vulnerability and a path-disclosure vulnerability because it fails to sufficiently sanitize user-supplied input.

Exploiting these issues could allow an attacker to obtain sensitive information and compromise the application and the underlying system; other attacks are also possible.

Crafty Syntax Live Help versions 2.x and versions 3.x are vulnerable. 

File-include:

http://www.example.com/path/admin.php?page=[RFI]

Path-disclosure:

http://www.example.com/livehelp/xmlhttp.php