WordPress Pretty Link Plugin Cross Site Scripting Vulnerability

2013-02-20T00:00:00
ID EDB-ID:38324
Type exploitdb
Reporter hiphop
Modified 2013-02-20T00:00:00

Description

WordPress Pretty Link Plugin Cross Site Scripting Vulnerability. CVE-2013-1636. Webapps exploit for php platform

                                        
                                            source: http://www.securityfocus.com/bid/58072/info

The Pretty Link plugin for WordPress is prone to a cross-site scripting vulnerability because it fails to properly sanitize user-supplied input.

An attacker may leverage this issue to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This can allow the attacker to steal cookie-based authentication credentials and launch other attacks.

Versions prior to Pretty Link 1.6.3 are vulnerable. 

http://www.example.com/wp-content/plugins/pretty-link/includes/version-2-kvasir/open-flash-chart.swf?get-data=(function(){alert(xss)})()