MediaWiki 1.x 'uselang' Parameter Cross Site Scripting Vulnerability

ID EDB-ID:37404
Type exploitdb
Reporter anonymous
Modified 2012-06-17T00:00:00


MediaWiki 1.x 'uselang' Parameter Cross Site Scripting Vulnerability. CVE-2012-2698. Webapps exploit for php platform


MediaWiki is prone to a cross-site scripting vulnerability because it fails to properly sanitize user-supplied input.

An attacker may leverage this issue to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This may let the attacker steal cookie-based authentication credentials and launch other attacks.

MediaWiki versions prior to 1.17.5, 1.18.4, and 1.19.1 are vulnerable.