Open Realty 2.5.x 'select_users_template' Parameter Local File Include Vulnerability

2012-03-05T00:00:00
ID EDB-ID:36910
Type exploitdb
Reporter Aung Khant
Modified 2012-03-05T00:00:00

Description

Open Realty 2.5.x 'select_users_template' Parameter Local File Include Vulnerability. CVE-2012-1112. Webapps exploit for php platform

                                        
                                            source: http://www.securityfocus.com/bid/52296/info

Open Realty is prone to a local file-include vulnerability because it fails to properly sanitize user-supplied input.

An attacker can exploit this vulnerability to obtain potentially sensitive information or to execute arbitrary local scripts in the context of the webserver process. This may allow the attacker to compromise the application and the computer; other attacks are also possible.

Open Realty version 2.5.8 is vulnerable; other versions may also be affected. 

http://www.example.com/open-realty2.5.8/?select_users_template=../../../../../../../../../../../../../../../etc/passwd%00