WordPress Alert Before Your Post Plugin - 'name' Parameter Cross Site Scripting Vulnerability

2011-11-21T00:00:00
ID EDB-ID:36323
Type exploitdb
Reporter Am!r
Modified 2011-11-21T00:00:00

Description

WordPress Alert Before Your Post Plugin 'name' Parameter Cross Site Scripting Vulnerability. CVE-2011-5107. Webapps exploit for php platform

                                        
                                            source: http://www.securityfocus.com/bid/50743/info

Alert Before Your Post plugin for WordPress is prone to a cross-site scripting vulnerability because it fails to properly sanitize user-supplied input.

An attacker may leverage this issue to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This can allow the attacker to steal cookie-based authentication credentials and launch other attacks. 

http://www.example.com/[path]/wp-content/plugins/alert-before-your-post/trunk/post_alert.php?name=[xss]