GoAhead WebServer 2.5 'goform/formTest' Multiple Cross Site Scripting Vulnerabilities

2011-11-18T00:00:00
ID EDB-ID:36319
Type exploitdb
Reporter Prabhu S Angadi
Modified 2011-11-18T00:00:00

Description

GoAhead WebServer 2.5 'goform/formTest' Multiple Cross Site Scripting Vulnerabilities. Remote exploit for windows platform

                                        
                                            source: http://www.securityfocus.com/bid/50729/info

GoAhead WebServer is prone to multiple cross-site scripting vulnerabilities because it fails to sufficiently sanitize user-supplied data.

An attacker may leverage these issues to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This may allow the attacker to steal cookie-based authentication credentials and launch other attacks.

GoAhead WebServer 2.5 is vulnerable; other versions may also be affected. 

http://www.example.com/goform/formTest?name=%3Cscript%3Ealert(4321)%3C/script%3E&address=%3Cscript%3Ealert(1234)%3C/script%3E