Splunk <= 4.1.6 'segment' Parameter Cross Site Scripting Vulnerability

2011-10-20T00:00:00
ID EDB-ID:36246
Type exploitdb
Reporter Filip Palian
Modified 2011-10-20T00:00:00

Description

Splunk 4.1.6 'segment' Parameter Cross Site Scripting Vulnerability. Remote exploits for multiple platform

                                        
                                            source: http://www.securityfocus.com/bid/50296/info

Splunk is prone to a cross-site scripting vulnerability because it fails to sufficiently sanitize user-supplied data.

An attacker may leverage this issue to execute arbitrary HTML and script code in an unsuspecting user's browser in the context of the affected site. This may allow the attacker to steal cookie-based authentication credentials and launch other attacks.

Splunk versions 4.2.2 and prior are vulnerable. 

http://www.example.com/en-US/prototype/segmentation_performance?lines=2&depth=2&segment=%3Cscript%3Ealert%281%29%3B%3C%2Fscript%3E&element=aaa&attribute=aaa&segmentation=flattened