Wireshark <= 1.4.3 - .pcap Memory Corruption Vulnerability

2011-02-03T00:00:00
ID EDB-ID:35314
Type exploitdb
Reporter Huzaifa Sidhpurwala
Modified 2011-02-03T00:00:00

Description

Wireshark 1.4.3 '.pcap' File Memory Corruption Vulnerability. CVE-2011-0538. Remote exploit for linux platform

                                        
                                            source: http://www.securityfocus.com/bid/46167/info

Wireshark is prone to a memory-corruption vulnerability because it fails to properly handle certain files.

Successful exploits may allow attackers to execute arbitrary code within the context of the affected application. Failed exploit attempts will likely crash the application. 

https://github.com/offensive-security/exploit-database-bin-sploits/raw/master/sploits/35314.pcap