HP Insight Diagnostics Online Edition 8.4 - 'search.php' CVE-2010-4111 - Cross-Site Scripting Vulnerability

2010-12-15T00:00:00
ID EDB-ID:35116
Type exploitdb
Reporter Richard Brain
Modified 2010-12-15T00:00:00

Description

HP Insight Diagnostics Online Edition 8.4 'search.php' CVE-2010-4111 Cross Site Scripting Vulnerability. CVE-2010-4111 . Webapps exploit for php platform

                                        
                                            source: http://www.securityfocus.com/bid/45420/info

HP Insight Diagnostics Online Edition is prone to multiple cross-site scripting vulnerabilities because it fails to properly sanitize user-supplied input.

An attacker may leverage this issue to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This may allow the attacker to steal cookie-based authentication credentials and to launch other attacks.

Versions prior to HP Insight Diagnostics Online Edition 8.5.1.3712 

http://www.example.com/hpdiags/frontend2/help/search.php?query="onmouseover="alert(1);