WordPress Twitter Feed Plugin 'url' Parameter - Cross-Site Scripting Vulnerability

2010-12-07T00:00:00
ID EDB-ID:35084
Type exploitdb
Reporter John Leitch
Modified 2010-12-07T00:00:00

Description

WordPress Twitter Feed Plugin 'url' Parameter Cross Site Scripting Vulnerability. Webapps exploit for php platform

                                        
                                            source: http://www.securityfocus.com/bid/45294/info

The Twitter Feed Plugin for WordPress is prone to a cross-site scripting vulnerability because it fails to properly sanitize user-supplied input.

An attacker may leverage this issue to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This can allow the attacker to steal cookie-based authentication credentials and launch other attacks.

Twitter Feed 0.3.1 is vulnerable; other versions may also be affected. 

http://www.example.com/wordpress/wp-content/plugins/wp-twitter-feed/magpie/scripts/magpie_debug.php?url=%3Cscript%3Ealert(0)%3C/script%3E