Spiceworks 'query' Parameter Cross-Site Scripting Vulnerability

2009-08-08T00:00:00
ID EDB-ID:34633
Type exploitdb
Reporter Adam Baldwin
Modified 2009-08-08T00:00:00

Description

Spiceworks 'query' Parameter Cross Site Scripting Vulnerability. Webapps exploit for php platform

                                        
                                            source:  http://www.securityfocus.com/bid/43248/info

Spiceworks is prone to a cross-site scripting vulnerability because it fails to properly sanitize user-supplied input.

An attacker may leverage this issue to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This may let the attacker steal cookie-based authentication credentials and launch other attacks.

Spiceworks 3.6.33156 and 4.1.39229 are vulnerable; other versions may also be affected.

http://www.example.com/search?query=--%3E%3Cscript%3Ealert%28document.cookie%29%3C%2Fscript%3E