Ez Poll Hoster Multiple Cross-Site Scripting Vulnerabilities

2009-12-14T00:00:00
ID EDB-ID:34342
Type exploitdb
Reporter Milos Zivanovic
Modified 2009-12-14T00:00:00

Description

Ez Poll Hoster Multiple Cross Site Scripting Vulnerabilities. Webapps exploit for php platform

                                        
                                            source: http://www.securityfocus.com/bid/41742/info

Ez Poll Hoster is prone to multiple cross-site scripting vulnerabilities because the application fails to properly sanitize user-supplied input.

An attacker may leverage these issues to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This may allow the attacker to steal cookie-based authentication credentials and to launch other attacks. 

The following example URIs are available:

http://www.example.com/eph/index.php?action=code&pid=[XSS]

http://www.example.com/eph/profile.php?action=view&uid=[XSS]