CSSTidy 1.3 - 'css_optimiser.php' Cross-Site Scripting Vulnerability

2010-07-11T00:00:00
ID EDB-ID:34296
Type exploitdb
Reporter John Leitch
Modified 2010-07-11T00:00:00

Description

CSSTidy 1.3 'css_optimiser.php' Cross Site Scripting Vulnerability. Webapps exploit for php platform

                                        
                                            source: http://www.securityfocus.com/bid/41552/info

CSSTidy is prone to a cross-site scripting vulnerability because it fails to properly sanitize user-supplied input. ImpressCMS versions that use the vulnerable application are also affected.

An attacker may leverage this issue to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This may allow the attacker to steal cookie-based authentication credentials and to launch other attacks.

CSSTidy 1.3 and ImpressCMS 1.2.1 are vulnerable; other versions may also be affected.

http://localhost/impresscms/plugins/csstidy/css_optimiser.php?url=%22%3E%3Cscript%3Ealert(0)%3C/script%3E