Miniwork Studio Canteen 1.0 Component for Joomla! SQL Injection and Local File Include Vulnerabilities

2010-07-05T00:00:00
ID EDB-ID:34250
Type exploitdb
Reporter Drosophila
Modified 2010-07-05T00:00:00

Description

Miniwork Studio Canteen 1.0 Component for Joomla! SQL Injection and Local File Include Vulnerabilities. CVE-2010-4977. Webapps exploit for php platform

                                        
                                            source: http://www.securityfocus.com/bid/41358/info

The Miniwork Studio Canteen component for Joomla! is prone to an SQL-injection vulnerability and a local file-include vulnerability because it fails to sufficiently sanitize user-supplied data.

Attackers can exploit the SQL-injection vulnerability to compromise the application, access or modify data, or exploit latent vulnerabilities in the underlying database.

An attacker can exploit the local file-include vulnerability using directory-traversal strings to view and execute arbitrary local files within the context of the webserver process. Information harvested may aid in further attacks.

Canteen 1.0 is vulnerable; other versions may also be affected.

http://www.example.com/index.php?option=com_canteen&controller=../../../../../etc/passwd%00