Mango Blog 1.4.1 - 'archives.cfm/search' Cross-Site Scripting Vulnerability

2010-05-03T00:00:00
ID EDB-ID:33916
Type exploitdb
Reporter MustLive
Modified 2010-05-03T00:00:00

Description

Mango Blog 1.4.1 'archives.cfm/search' Cross Site Scripting Vulnerability. Webapps exploit for cfm platform

                                        
                                            source: http://www.securityfocus.com/bid/39864/info

Mango Blog is prone to a cross-site scripting vulnerability because it fails to properly sanitize user-supplied input.

An attacker may leverage this issue to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This may allow the attacker to steal cookie-based authentication credentials and to launch other attacks.

Versions prior to Mango Blog 1.4.2 are vulnerable. 

http://www.example.com/archives.cfm/search/?term=%3Cbody%20onload=alert(document.cookie)%3E