Zikula Application Framework 1.2.2 ZLanguage.php lang Parameter XSS

2010-04-13T00:00:00
ID EDB-ID:33884
Type exploitdb
Reporter High-Tech Bridge SA
Modified 2010-04-13T00:00:00

Description

Zikula Application Framework 1.2.2 ZLanguage.php lang Parameter XSS. CVE-2010-1724. Webapps exploit for php platform

                                        
                                            source: http://www.securityfocus.com/bid/39717/info

Zikula Application Framework is prone to a cross-site scripting vulnerability because it fails to sufficiently sanitize user-supplied data.

An attacker may leverage this issue to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This may allow the attacker to steal cookie-based authentication credentials and to launch other attacks.

Zikula Application Framework 1.2.2 is vulnerable; other versions may also be affected. 

http://www.example.com/?lang=en%27%22%3E%3Cimg%20src=0%20onerror=alert%28document.cookie%29%3E