phpCOIN 1.2.1 - 'mod' Parameter Local File Include Vulnerability

2010-03-06T00:00:00
ID EDB-ID:33718
Type exploitdb
Reporter _mlk_
Modified 2010-03-06T00:00:00

Description

phpCOIN 1.2.1 'mod' Parameter Local File Include Vulnerability. Webapps exploit for php platform

                                        
                                            source: http://www.securityfocus.com/bid/38576/info

phpCOIN is prone to a local file-include vulnerability because it fails to properly sanitize user-supplied input.

An attacker can exploit this vulnerability to obtain potentially sensitive information and execute arbitrary local scripts in the context of the webserver process. This may allow the attacker to compromise the application and the underlying computer; other attacks are also possible.

phpCOIN 1.2.1 is vulnerable; other versions may also be affected. 

http://www.example.com/phpcoin/mod.php?mod=/../../../../../../proc/self/environ%00