MyBB 1.4.8 - 'search.php' SQL Injection Vulnerability

2009-09-19T00:00:00
ID EDB-ID:33232
Type exploitdb
Reporter $qL_DoCt0r
Modified 2009-09-19T00:00:00

Description

MyBB 1.4.8 'search.php' SQL Injection Vulnerability. Webapps exploit for php platform

                                        
                                            source: http://www.securityfocus.com/bid/36460/info

MyBB is prone to an SQL-injection vulnerability because it fails to sufficiently sanitize user-supplied data before using it in an SQL query.

Exploiting this issue could allow an attacker to compromise the application, access or modify data, or exploit latent vulnerabilities in the underlying database.

MyBB 1.4.8 is vulnerable; other versions may also be affected.

The following examples are available:

simple query: ' or 1=1--
blind query: ' having 1=1--