XOOPS 2.3.3 \\\'op\\\' Parameter Multiple Cross-Site Scripting Vulnerabilities

2009-06-30T00:00:00
ID EDB-ID:33131
Type exploitdb
Reporter Sense of Security
Modified 2009-06-30T00:00:00

Description

XOOPS 2.3.3 \\'op\\' Parameter Multiple Cross Site Scripting Vulnerabilities. CVE-2009-2783. Webapps exploit for php platform

                                        
                                            source: http://www.securityfocus.com/bid/35895/info

XOOPS is prone to multiple cross-site scripting vulnerabilities because it fails to sufficiently sanitize user-supplied data.

An attacker may leverage these issues to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This may allow the attacker to steal cookie-based authentication credentials and to launch other attacks.

XOOPS 2.3.3 is vulnerable; other versions may be affected as well. 

http://www.example.com/xoops-2.3.3/htdocs/modules/pm/viewpmsg.php?op='"><script>alert('vulnerable')</script>
http://www.example.com/xoops-2.3.3/htdocs/modules/profile/user.php?"><script>alert('vulnerable')</script>