Miniweb 2.0 Site Builder Module Multiple Cross-Site Scripting Vulnerabilities

2009-06-29T00:00:00
ID EDB-ID:33127
Type exploitdb
Reporter Moudi
Modified 2009-06-29T00:00:00

Description

Miniweb 2.0 Site Builder Module Multiple Cross Site Scripting Vulnerabilities. Webapps exploit for php platform

                                        
                                            source: http://www.securityfocus.com/bid/35871/info

The Site Builder module for Miniweb is prone to multiple cross-site scripting vulnerabilities because it fails to sufficiently sanitize user-supplied data.

An attacker may leverage these issues to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This may allow the attacker to steal cookie-based authentication credentials and to launch other attacks.

Site Builder module for Miniweb 2.0 is affected. 

http://www.example.com/sitebuilder/index.php/"><script>alert(document.cookie);</script>
http://www.example.com/sitebuilder/index.php?sitebuilder_id="><script>alert(document.cookie);</script>