Lussumo Vanilla 1.1.5/1.1.7 - 'updatecheck.php' Cross-Site Scripting Vulnerability

ID EDB-ID:33013
Type exploitdb
Reporter Gerendi Sandor Attila
Modified 2009-05-15T00:00:00


Lussumo Vanilla 1.1.5/1.1.7 'updatecheck.php' Cross Site Scripting Vulnerability. CVE-2009-1845. Webapps exploit for php platform


Vanilla is prone to a cross-site scripting vulnerability because it fails to properly sanitize user-supplied input.

An attacker may leverage this issue to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This may allow the attacker to steal cookie-based authentication credentials and to launch other attacks.

Versions prior to Vanilla 1.1.8 are vulnerable.<script>alert(123)</script>