Gallery 2.0 - Multiple Cross-Site Scripting Vulnerabilities

2008-09-08T00:00:00
ID EDB-ID:32340
Type exploitdb
Reporter sl4xUz
Modified 2008-09-08T00:00:00

Description

Gallery 2.0 Multiple Cross Site Scripting Vulnerabilities. Webapps exploit for php platform

                                        
                                            source: http://www.securityfocus.com/bid/31060/info

Gallery is prone to multiple cross-site scripting vulnerabilities because it fails to sufficiently sanitize user-supplied data.

An attacker may leverage these issues to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This may allow the attacker to steal cookie-based authentication credentials and to launch other attacks.

Gallery 2.0 is vulnerable; other versions may also be affected.

http://www.example.com/path/search.php?title=[XSS]
http://www.example.com/path/search.php?description=[XSS]
http://www.example.com/path/search.php?author=[XSS]
http://www.example.com/path/login.php?return=[XSS]