vBulletin <= 3.7.1 Moderation Control Panel 'redirect' Parameter Cross-Site Scripting Vulnerability

2008-06-19T00:00:00
ID EDB-ID:31939
Type exploitdb
Reporter Jessica Hope
Modified 2008-06-19T00:00:00

Description

vBulletin 3.7.1 Moderation Control Panel 'redirect' Parameter Cross-Site Scripting Vulnerability. Webapps exploit for php platform

                                        
                                            source: http://www.securityfocus.com/bid/29817/info

vBulletin is prone to a cross-site scripting vulnerability that occurs in the MCP (moderation control panel) because the application fails to properly sanitize user-supplied input.

An attacker may leverage this issue to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This may help the attacker steal cookie-based authentication credentials and launch other attacks.

vBulletin 3.7.1 PL1 and 3.6.10 PL1 are vulnerable; prior versions may also be affected. 

http://www.example.com/vB3/modcp/index.php?redirect=data:text/html;base64,PHNjcmlwdD5hbGVydCgnWFNTJyk8L3NjcmlwdD4K
http://www.example.com/vB3/modcp/index.php?redirect={XSS}