Tornado Knowledge Retrieval System 4.2 - 'p' Parameter Cross-Site Scripting Vulnerability

2008-06-10T00:00:00
ID EDB-ID:31892
Type exploitdb
Reporter Unohope
Modified 2008-06-10T00:00:00

Description

Tornado Knowledge Retrieval System 4.2 'p' Parameter Cross Site Scripting Vulnerability. CVE-2008-5264 . Webapps exploit for cgi platform

                                        
                                            source: http://www.securityfocus.com/bid/29626/info

Tornado Knowledge Retrieval System is prone to a cross-site scripting vulnerability because it fails to properly sanitize user-supplied input.

An attacker may leverage this issue to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This may let the attacker steal cookie-based authentication credentials and launch other attacks.

Tornado Knowledge Retrieval System 4.2 is vulnerable; prior versions may also be affected.

http://www.example.com/tornado/searcher.exe?v=root&p=<script>alert(/xss/)</script>